Click or drag to resize

GH_Component Properties

The GH_Component type exposes the following members.

Properties
  NameDescription
Public propertyClippingBox
Gets the clipping box for all preview geometry drawn by this component and all associated parameters.
Protected propertyHelpDescription
Override this method if you want the help topic content to be more than the Component description.
Public propertyHidden
Gets or sets the hidden flag for this component. Does not affect Hidden flags on parameters associated with this component.
Public propertyInConstructor
Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public propertyInstanceDescription (Overrides GH_InstanceDescriptionInstanceDescription.)
Public propertyIsBakeCapable
Public propertyIsDataProvider
Components are never Data providers. Only the output parameters can be considered to be providers.
(Overrides GH_ActiveObjectIsDataProvider.)
Public propertyIsPreviewCapable
If a single parameter is PreviewCapable, so is the component. Override this property if you need special Preview flags.
Public propertyIsValidPrincipalParameterIndex
Gets whether the MasterParameterIndex property identifies a valid parameter.
Public propertyLocked
Gets or sets the Locked state for this Component. This also sets locked states for all input and output parameters.
(Overrides GH_ActiveObjectLocked.)
Public propertyMessage
Gets or sets a custom message to be displayed underneath the component. This message is not serialized and should be assigned on every solution anew.
Public propertyParams
Gets the parameter manager object for this component.
Public propertyPrincipalParameterIndex
Gets or sets the principal parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular principal parameter detection will kick in.
Public propertyProcessorTime
Gets the total processor time (profiler) spend by this component and all input parameters.
(Overrides GH_ActiveObjectProcessorTime.)
Public propertyRunCount
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution. This property will return -1 if no valid runcount is available.
Public propertyRuntimeMessageLevel
Returns the worst case runtime warning level of me and all my parameters
(Overrides GH_ActiveObjectRuntimeMessageLevel.)
Top
See Also