Click or drag to resize

GH_IndexRuleSet Class

A collection of index rules.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.DataGH_IndexRuleSet

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_IndexRuleSet

The GH_IndexRuleSet type exposes the following members.

Constructors
  NameDescription
Public methodGH_IndexRuleSet
Blank constructor. Creates an empty collection of rules.
Top
Properties
  NameDescription
Public propertyCount
Gets the number of rules defined in this collection.
Public propertyRule
Gets the rule at the specified index.
Top
Methods
  NameDescription
Public methodAddAnyDigitRule
Append a rule for any single digit.
Public methodAddAnyDigitsRule
Append a rule for any amount of digits.
Public methodAddDigitPatternRule(Int32)
Append a rule for filtering digit patterns.
Public methodAddDigitPatternRule(Int32, Int32)
Append a rule for filtering digit patterns. This pattern does not have an upper bound.
Public methodAddDigitPatternRule(Int32, Int32, Int32)
Append a rule for filtering digit patterns.
Public methodAddDigitRule
Append a single digit rule.
Public methodAddRangePatternRule
Append a rule for filtering range patterns.
Public methodAddRangeRule
Append a single range rule.
Public methodEvaluate
Evaluate the index given the local rules.
Top
See Also