Click or drag to resize

GH_Arc Class

Represents a 3D circular arc. GH_Arc re-implements the OpenNURBS OnArc class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooArc
    Grasshopper.Kernel.TypesGH_GeometricGooArc
      Grasshopper.Kernel.TypesGH_Arc

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Arc : GH_GeometricGoo<Arc>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_Arc type exposes the following members.

Constructors
  NameDescription
Public methodGH_Arc
Default constructor
Public methodGH_Arc(Arc)
Create a duplicate of another arc
Public methodGH_Arc(GH_Arc)
Create a duplicate of another arc
Top
Properties
  NameDescription
Public propertyBoundingbox
Gets the boundingbox for this geometry.
(Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsValid
Gets the validity of this instance.
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom (Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GeometricGooTCastToQ(Q).)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateArc
Create a duplicate of this arc.
Public methodDuplicateGeometry
Create a duplicate of this arc.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodEmitProxy
Returns a proxy that represents this arc. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also