GH_Dimension Class |
Namespace: Grasshopper.Kernel.Types
The GH_Dimension type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Dimension |
Default constructor, creates an invalid dimension.
|
![]() | GH_Dimension(Dimension) |
Create a duplicate of an existing dimension.
|
![]() | GH_Dimension(GH_Dimension) |
Create a duplicate of another GH_Dimension. This constructor also copies reference data.
|
![]() | GH_Dimension(Guid) |
Create a new referenced dimension that references a Rhino dimension with the specified ID.
|
![]() | GH_Dimension(ObjRef) | Initializes a new instance of the GH_Dimension class |
![]() | GH_Dimension(Dimension, ModelAnnotationStyle) |
Create a duplicate of an existing dimension.
|
Name | Description | |
---|---|---|
![]() | Boundingbox | (Inherited from GH_AnnotationBase.) |
![]() | ClippingBox | (Inherited from GH_AnnotationBase.) |
![]() | IsGeometryLoaded |
Gets the load state of this annotation object. The annotation is considered to be loaded when the local annotation instance is not null.
(Inherited from GH_AnnotationBase.) |
![]() | IsReferencedGeometry |
Gets a value indicating whether or not this geometry is referenced.
Not all IGH_GeometricGoo implementations support referenced geometry.
(Inherited from GH_GeometricGooT.) |
![]() | IsValid |
Gets the validity of this dimension. If the dimension is referenced but cannot be loaded, then the dimension is not valid.
(Inherited from GH_AnnotationBase.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Inherited from GH_AnnotationBase.) |
![]() | ReferenceID | (Inherited from GH_AnnotationBase.) |
![]() | Style | (Inherited from GH_AnnotationBase.) |
![]() | TypeDescription | (Inherited from GH_AnnotationBase.) |
![]() | TypeName | (Inherited from GH_AnnotationBase.) |
![]() | Value | |
![]() | ValueType | (Overrides GH_AnnotationBaseValueType.) |
Name | Description | |
---|---|---|
![]() | BakeGeometry | (Inherited from GH_AnnotationBase.) |
![]() | CastFrom |
Attempt a cast from generic object.
(Inherited from GH_GeometricGooT.) |
![]() | CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Inherited from GH_AnnotationBase.) |
![]() | CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_AnnotationBaseCastToT(T).) |
![]() | CastToQ(Q) |
Attempt a cast to type T.
(Inherited from GH_GeometricGooT.) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | ClearCaches |
Clears all volatile caches for this instance. The boundingbox is cleared, and if the annotation is referenced,
the local instance of the annotation is erased.
(Inherited from GH_AnnotationBase.) |
![]() | DrawViewportMeshes | (Inherited from GH_AnnotationBase.) |
![]() | DrawViewportWires | (Inherited from GH_AnnotationBase.) |
![]() | Duplicate | (Inherited from GH_AnnotationBase.) |
![]() | DuplicateAnnotation |
Create a duplicate of this annotation.
(Inherited from GH_AnnotationBase.) |
![]() | DuplicateGeometry |
Create a duplicate of this annotation.
(Inherited from GH_AnnotationBase.) |
![]() | EmitProxy |
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from GH_GeometricGooT.) |
![]() | GetBoundingBox | (Inherited from GH_AnnotationBase.) |
![]() | GetOverrides | (Inherited from GH_AnnotationBase.) |
![]() | LoadGeometry |
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Inherited from GH_AnnotationBase.) |
![]() | LoadGeometry(RhinoDoc) |
If the annotation is referenced and not yet loaded, attempts to load the leader.
(Inherited from GH_AnnotationBase.) |
![]() | Morph | (Inherited from GH_AnnotationBase.) |
![]() | Read | (Inherited from GH_AnnotationBase.) |
![]() | ScriptVariable | (Inherited from GH_AnnotationBase.) |
![]() | SetOverrides | (Inherited from GH_AnnotationBase.) |
![]() | ToString |
Format the dimension using default grasshopper formatting logic.
(Inherited from GH_AnnotationBase.) |
![]() | Transform | (Inherited from GH_AnnotationBase.) |
![]() | Write | (Inherited from GH_AnnotationBase.) |