Click or drag to resize

GH_MeshFace Class

Represents a tri or quad mesh face. GH_MeshFace works similar to the OpenNURBS OnMeshFace class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooMeshFace
    Grasshopper.Kernel.TypesGH_MeshFace

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_MeshFace : GH_Goo<MeshFace>

The GH_MeshFace type exposes the following members.

Constructors
  NameDescription
Public methodGH_MeshFace
Default constructor. Sets all corners to 0.
Public methodGH_MeshFace(GH_MeshFace)
Create a duplicate of another mesh face
Public methodGH_MeshFace(MeshFace)
Create a duplicate of another mesh face.
Public methodGH_MeshFace(Int32, Int32, Int32)
Create a triangular mesh face from 3 corners indices.
Public methodGH_MeshFace(Int32, Int32, Int32, Int32)
Create a quadrangular mesh face from 4 corners indices.
Top
Properties
  NameDescription
Public propertyIsValid
Test for validity. No negative indices are allowed and only C and D are allowed to be identical.
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate
Create a duplicate of this Mesh face.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateMeshFace
Create a duplicate of this Mesh face.
Public methodEmitProxy
Returns a proxy that represents this mesh face. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the mesh face using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also