Click or drag to resize

GH_ObjectUndoAction Class

Utility base class for undo actions that operate on a single IGH_DocumentObject.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.UndoGH_UndoAction
    Grasshopper.Kernel.UndoGH_ObjectUndoAction
      More...

Namespace:  Grasshopper.Kernel.Undo
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_ObjectUndoAction : GH_UndoAction

The GH_ObjectUndoAction type exposes the following members.

Constructors
  NameDescription
Protected methodGH_ObjectUndoAction
Initializes a new instance of the GH_ObjectUndoAction class
Top
Properties
  NameDescription
Top
Methods
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.UndoGH_UndoAction
    Grasshopper.Kernel.UndoGH_ObjectUndoAction
      Grasshopper.Kernel.Undo.ActionsGH_DataMatchingAction
      Grasshopper.Kernel.Undo.ActionsGH_DataModificationAction
      Grasshopper.Kernel.Undo.ActionsGH_HiddenAction
      Grasshopper.Kernel.Undo.ActionsGH_IconDisplayAction
      Grasshopper.Kernel.Undo.ActionsGH_IconOverrideAction
      Grasshopper.Kernel.Undo.ActionsGH_LayoutAction
      Grasshopper.Kernel.Undo.ActionsGH_LockedAction
      Grasshopper.Kernel.Undo.ActionsGH_NickNameAction
      Grasshopper.Kernel.Undo.ActionsGH_PersistentDataActionT
      Grasshopper.Kernel.Undo.ActionsGH_PivotAction
      Grasshopper.Kernel.Undo.ActionsGH_WireDisplayAction