Description:

Called for each frame. Starting at 0.0.

Syntax:
public abstract bool AnimateObject(
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
double dPos,
BinaryArchiveReader archive_start,
BinaryArchiveReader archive_stop
)
Parameters:
  • doc
  • Type: RhinoDoc
  • doc is the current document.
  • transform
  • Type: Rhino.Geometry.Transform
  • transform is a transformation matrix. The matrix is set to identity the first time an object is associated with a snapshot. After that the matrix is updated when the object is transformed(scale, rotate etc.).
  • dPos
  • Type: double
  • dPos is the current frame. Starting at 0.0.
  • archive_start
  • Type: BinaryArchiveReader
  • archive_start is a archive to the data of the starting position.
  • archive_stop
  • Type: BinaryArchiveReader
  • archive_stop is a archive to the data of the ending position.
Returns:
Type: bool
Available since:
6.0

Nothing found