Description:

Called when the user saves a snapshot and SupportsObjects() and SupportsObject(Rhino.DocObjects.RhinoObject doc_object) returns true.

Syntax:
public abstract bool SaveObject(
RhinoDoc doc,
RhinoObject doc_object,
ref Transform transform,
BinaryArchiveWriter archive
)
Parameters:
  • doc
  • Type: RhinoDoc
  • doc is the current document.
  • transform
  • Type: Rhino.Geometry.Transform
  • transform is a transformation matrix. The matrix is set to identity the first time an object is associated with a snapshot. After that the matrix is updated when the object is transformed(scale, rotate etc.).
Returns:
Type: bool
True if successful, otherwise false.
Available since:
6.0

Nothing found