Description:

Gets indices of faces connected to an edge.

Syntax:
public int GetConnectedFaces(
int topologyEdgeIndex,
out bool faceOrientationMatchesEdgeDirection
)
Parameters:
  • topologyEdgeIndex
  • Type: int
  • An index of a topology edge that is queried.
  • faceOrientationMatchesEdgeDirection
  • Type: bool
  • An array of Boolean values that explains whether each face direction matches the direction of the specified edge.
Returns:
Type: int
An array of face indices the edge borders. This might be empty on error.
Available since:
5.0

Description:

Gets indices of faces connected to an edge.

Syntax:
public int GetConnectedFaces(
int topologyEdgeIndex
)
Parameters:
  • topologyEdgeIndex
  • Type: int
  • An index of a topology edge that is queried.
Returns:
Type: int
An array of face indices the edge borders. This might be empty on error.
Available since:
5.0

Nothing found