Description:

Divides a mesh edge to create two or more triangles

Syntax:
public bool SplitEdge(
int topologyEdgeIndex,
double t
)
Parameters:
  • topologyEdgeIndex
  • Type: int
  • Edge to divide
  • t
  • Type: double
  • Parameter along edge. This is the same as getting an EdgeLine and calling PointAt(t) on that line
Returns:
Type: bool
True if successful
Available since:
5.0

Description:

Divides a mesh edge to create two or more triangles

Syntax:
public bool SplitEdge(
int topologyEdgeIndex,
Point3d point
)
Parameters:
  • topologyEdgeIndex
  • Type: int
  • Edge to divide
  • point
  • Type: Point3d
  • Location to perform the split
Returns:
Type: bool
True if successful
Available since:
5.0

Nothing found