Description:

Advances the cyclic redundancy check value remainder given a byte array. http://en.wikipedia.org/wiki/Cyclic_redundancy_check.

Syntax:
public static uint CRC32(
uint currentRemainder,
byte buffer
)
Parameters:
  • currentRemainder
  • Type: uint
  • The remainder from which to start.
  • buffer
  • Type: byte
  • The value to add to the current remainder.
Returns:
Type: uint
The new current remainder.
Available since:
5.0

Description:

Advances the cyclic redundancy check value remainder given a double . http://en.wikipedia.org/wiki/Cyclic_redundancy_check.

Syntax:
public static uint CRC32(
uint currentRemainder,
double value
)
Parameters:
  • currentRemainder
  • Type: uint
  • The remainder from which to start.
  • value
  • Type: double
  • The value to add to the current remainder.
Returns:
Type: uint
The new current remainder.
Available since:
5.0

Description:

Advances the cyclic redundancy check value remainder given a int . http://en.wikipedia.org/wiki/Cyclic_redundancy_check.

Syntax:
public static uint CRC32(
uint currentRemainder,
int value
)
Parameters:
  • currentRemainder
  • Type: uint
  • The remainder from which to start.
  • value
  • Type: int
  • The value to add to the current remainder.
Returns:
Type: uint
The new current remainder.
Available since:
5.0

CRC32 method

Class:  Rhino.RhinoMath

Nothing found