Description:
Expert tool to evaluate sectional curvature from surface derivatives and section plane normal.
Parameters:
- ds
- Type: Rhino.Geometry.Vector3d
- First partial derivative.
- dt
- Type: Rhino.Geometry.Vector3d
- First partial derivative.
- dss
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- dst
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- dtt
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- planeNormal
- Type: Rhino.Geometry.Vector3d
- Unit normal to section plane.
- k
- Type: Rhino.Geometry.Vector3d
- Sectional curvature. Curvature of the intersection curve of the surface and plane through the surface point where the partial derivatives were evaluated.
Returns:
Type: bool
True if successful. False if first partials are not linearly independent, in which case the k is set to zero.
Available since:
8.16