Description:

Computes the scale factor for changing the measurements unit systems.

Syntax:
public static double UnitScale(
UnitSystem from,
double fromMetersPerUnit,
UnitSystem to,
double toMetersPerUnit
)
Parameters:
  • fromMetersPerUnit
  • Type: double
  • For custom units, specify the meters per unit.
  • to
  • Type: UnitSystem
  • The system to convert measurements into.
  • toMetersPerUnit
  • Type: double
  • For custom units, specify the meters per unit.
Returns:
Type: double
A scale multiplier.
Available since:
8.0

Description:

Computes the scale factor for changing the measurements unit systems.

Syntax:
public static double UnitScale(
UnitSystem from,
UnitSystem to
)
Parameters:
  • to
  • Type: UnitSystem
  • The system to convert measurements into.
Returns:
Type: double
A scale multiplier.
Available since:
5.0

/
/
/
UnitScale

UnitScale method

Class:  Rhino.RhinoMath

Nothing found