Description:
Expert tool to evaluate partial derivatives of surface unit normal.
Parameters:
- ds
- Type: Rhino.Geometry.Vector3d
- First partial derivative.
- dt
- Type: Rhino.Geometry.Vector3d
- First partial derivative.
- dss
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- dst
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- dtt
- Type: Rhino.Geometry.Vector3d
- Second partial derivative.
- ns
- Type: Rhino.Geometry.Vector3d
- First partial derivative of unit normal. If the Jacobian is degenerate, ns is set to zero.
- nt
- Type: Rhino.Geometry.Vector3d
- First partial derivative of unit normal. If the Jacobian is degenerate, nt is set to zero.
Returns:
Type: bool
True if Jacobian is non-degenerate, False if Jacobian is degenerate.
Available since:
7.0