Description:

Determines whether a float value is valid within the RhinoCommon context. Rhino does not use Single.NaN by convention, so this test evaluates to True if: x is not equal to RhinoMath.UnsetValue, System.Single.IsNaN(x) evaluates to false System.Single.IsInfinity(x) evaluates to false

Syntax:
public static bool IsValidSingle(
float x
)
Parameters:
  • x
  • Type: float
  • float number to test for validity.
Returns:
Type: bool
True if the number if valid, False if the number is NaN, Infinity or Unset.
Available since:
5.0

/
/
/
IsValidSingle

IsValidSingle method

Class:  Rhino.RhinoMath

Nothing found