Rhino C++ API  8.6
Classes | Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
IRhRdkNewContentCtrl Class Referenceabstract

#include <RhRdkNewContentCtrl.h>

Inheritance diagram for IRhRdkNewContentCtrl:
IRhinoUiWithController IRhinoUiWindow IRhinoUiControllerEventWatcher

Classes

class  IAssignBy
 

Public Types

enum  AssignBys : unsigned int {
  AssignBys::Unset, AssignBys::Layer, AssignBys::Parent, AssignBys::Object,
  AssignBys::Varies, AssignBys::PlugIn
}
 
enum  Styles : unsigned int {
  Styles::Material, Styles::Environment, Styles::Texture, Styles::MaterialIPE,
  Styles::MaterialAssignByIPE
}
 

Public Member Functions

virtual bool CloseDropDown (void)=0
 
virtual ON_wString DebugText (void) const =0
 
virtual AssignBys GetAssignBy (void) const =0
 
virtual bool GetForcedVaries (void) const =0
 
virtual bool GetSelection (OUT CRhRdkContentArray &aContent) const =0
 
virtual bool GetSelection (OUT CRhRdkInstanceIdArray &aInstance) const =0
 
virtual bool IsDropDownOpen (void) const =0
 
virtual CRhRdkContent::Kinds Kind (void) const =0
 
virtual bool OpenContextMenu (CPoint point)=0
 
virtual bool OpenDropDown (void)=0
 
virtual bool SetAssignBy (AssignBys a)=0
 
virtual void SetDebugText (const wchar_t *wsz)=0
 
virtual void SetForcedVaries (bool b=true)=0
 
virtual bool SetSelection (const CRhRdkContentArray &aContent)=0
 
virtual bool SetSelection (const CRhRdkInstanceIdArray &aInstance)=0
 
virtual void SetShowContextMenu (bool bShow)=0
 
virtual void SetShowNewButtonInDropDown (bool bShow)=0
 
virtual void SetShowPlugInItemInDropDown (bool bShow)=0
 
virtual bool ShowContextMenu (void) const =0
 
virtual bool ShowNewButtonInDropDown (void) const =0
 
virtual bool ShowPlugInItemInDropDown (void) const =0
 
virtual void UpdateView (void)=0
 
- Public Member Functions inherited from IRhinoUiWithController
virtual std::shared_ptr< IRhinoUiControllerController (void) const =0
 
virtual ON_UUID ControllerId (void) const =0
 
virtual void SetController (std::shared_ptr< IRhinoUiController > con)=0
 
- Public Member Functions inherited from IRhinoUiWindow
virtual ON_wString Caption (bool bAlwaysEnglish=false) const =0
 
virtual void Delete (void)=0
 
virtual void Enable (bool bEnable)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void GetScreenCoords (ON_4iRect &rectOut) const =0
 
virtual HWND GetWindow (void)=0
 
virtual bool IsCreated (void) const =0
 
virtual bool IsEnabled (void) const =0
 
virtual bool IsShown (void) const =0
 
virtual void Move (const ON_4iRect &rect, bool bRepaint=false, bool bRepaintBorder=false)=0
 
virtual HWND Parent (void) const =0
 
virtual void Refresh (bool bImmediate=false)=0
 
virtual void SetFocus (void)=0
 
virtual void SetParent (HWND parent)=0
 
virtual void Show (bool bShow)=0
 
- Public Member Functions inherited from IRhinoUiControllerEventWatcher
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void OnControllerActivatedEvent (IRhinoUiController &con)=0
 
virtual void OnEvent (IRhinoUiController &con, const UUID &uuidData, IRhinoUiController::EventPriority ep, const IRhinoUiEventInfo *pInfo)=0
 

Static Public Member Functions

static IRhRdkNewContentCtrlNew (Styles s, RhRdkUiFrameworks f)
 
static void NewDataSources (OUT ON_SimpleArray< IRhinoUiDataSource * > &aDS, const CRhRdkContentKindList &kinds, const CRhRdkDocument &rdkDoc)
 
static RDK_DEPRECATED void NewDataSources (OUT ON_SimpleArray< IRhinoUiDataSource * > &aDS, const CRhRdkContentKindList &kinds, const CRhRdkDocument *pRdkDoc)
 
static void RequiredDataSources (OUT ON_SimpleArray< ON_UUID > &aId)
 

Protected Member Functions

virtual ~IRhRdkNewContentCtrl ()
 
- Protected Member Functions inherited from IRhinoUiWithController
virtual ~IRhinoUiWithController ()
 
- Protected Member Functions inherited from IRhinoUiWindow
virtual ~IRhinoUiWindow ()
 
- Protected Member Functions inherited from IRhinoUiControllerEventWatcher
virtual ~IRhinoUiControllerEventWatcher ()
 

Detailed Description

'NCC'.

This is a replacement for CRhRdkContentCtrl and allows a UI to display a chosen content with a drop-down list of content thumbnails to choose from.

STARTING WITH RHINO 8, THIS CONTROL IS DEPRECATED AND DOES NOT WORK. See [DEPCTL]

Member Enumeration Documentation

◆ AssignBys

enum IRhRdkNewContentCtrl::AssignBys : unsigned int
strong
Enumerator
Unset 
Layer 
Parent 
Object 
Varies 
PlugIn 

◆ Styles

enum IRhRdkNewContentCtrl::Styles : unsigned int
strong
Enumerator
Material 
Environment 
Texture 
MaterialIPE 
MaterialAssignByIPE 

Constructor & Destructor Documentation

◆ ~IRhRdkNewContentCtrl()

virtual IRhRdkNewContentCtrl::~IRhRdkNewContentCtrl ( )
inlineprotectedvirtual

Member Function Documentation

◆ CloseDropDown()

virtual bool IRhRdkNewContentCtrl::CloseDropDown ( void  )
pure virtual

Make the control close its drop-down thumbnail list (if open). The drop-down list also closes automatically when it loses the focus.

Returns
true if successful, else false.

◆ DebugText()

virtual ON_wString IRhRdkNewContentCtrl::DebugText ( void  ) const
pure virtual

◆ GetAssignBy()

virtual AssignBys IRhRdkNewContentCtrl::GetAssignBy ( void  ) const
pure virtual

Get the assign-by for the Object Material UI. This UI not only allows selection of contents, but also of special items. These items are listed in the AssignBys enum.

◆ GetForcedVaries()

virtual bool IRhRdkNewContentCtrl::GetForcedVaries ( void  ) const
pure virtual

◆ GetSelection() [1/2]

virtual bool IRhRdkNewContentCtrl::GetSelection ( OUT CRhRdkContentArray aContent) const
pure virtual

Get the selected contents.

Parameters
aContentaccepts the contents.
Returns
true if successful, else false.

◆ GetSelection() [2/2]

virtual bool IRhRdkNewContentCtrl::GetSelection ( OUT CRhRdkInstanceIdArray aInstance) const
pure virtual

Get the selected contents' instance ids.

Parameters
aInstanceaccepts the instance ids.
Returns
true if successful, else false.

◆ IsDropDownOpen()

virtual bool IRhRdkNewContentCtrl::IsDropDownOpen ( void  ) const
pure virtual
Returns
true if the drop-down list is open, else false.

◆ Kind()

virtual CRhRdkContent::Kinds IRhRdkNewContentCtrl::Kind ( void  ) const
pure virtual
Returns
The content kind that this control displays.

◆ New()

static IRhRdkNewContentCtrl* IRhRdkNewContentCtrl::New ( Styles  s,
RhRdkUiFrameworks  f 
)
static

Create a new content control.

Parameters
sspecifies the style of the control.
Returns
An interface to the new content control if successful, else null.

◆ NewDataSources() [1/2]

static void IRhRdkNewContentCtrl::NewDataSources ( OUT ON_SimpleArray< IRhinoUiDataSource * > &  aDS,
const CRhRdkContentKindList kinds,
const CRhRdkDocument rdkDoc 
)
static

Creates new data sources for managing a simple selection of document-resident contents.

Parameters
aDSaccepts all the new data sources that the NCC needs in order to function.
rdkDocspecifies the document within which the contents reside.
kindsspecifies the allowed content kinds. The caller shall delete the returned data sources when they are longer needed.

◆ NewDataSources() [2/2]

static RDK_DEPRECATED void IRhRdkNewContentCtrl::NewDataSources ( OUT ON_SimpleArray< IRhinoUiDataSource * > &  aDS,
const CRhRdkContentKindList kinds,
const CRhRdkDocument pRdkDoc 
)
static

This method is deprecated in favor of the one below.

◆ OpenContextMenu()

virtual bool IRhRdkNewContentCtrl::OpenContextMenu ( CPoint  point)
pure virtual

Make the control open its context menu.

Parameters
pointis the client coordinates to display the menu at.
Returns
true if successful, else false.

◆ OpenDropDown()

virtual bool IRhRdkNewContentCtrl::OpenDropDown ( void  )
pure virtual

Make the control open its drop-down thumbnail list (if closed).

Returns
true if successful, else false.

◆ RequiredDataSources()

static void IRhRdkNewContentCtrl::RequiredDataSources ( OUT ON_SimpleArray< ON_UUID > &  aId)
static

Returns the ids of the data sources needed to make the control work.

◆ SetAssignBy()

virtual bool IRhRdkNewContentCtrl::SetAssignBy ( AssignBys  a)
pure virtual

Set the assign-by for the Object Material UI.

Parameters
ais the assign-by setting.
Returns
true if successful, else false.

◆ SetDebugText()

virtual void IRhRdkNewContentCtrl::SetDebugText ( const wchar_t *  wsz)
pure virtual

◆ SetForcedVaries()

virtual void IRhRdkNewContentCtrl::SetForcedVaries ( bool  b = true)
pure virtual

Set the control to 'varies'. Useful for clients that only support single content selections and want the control to display (varies) when more than one content is selected.

◆ SetSelection() [1/2]

virtual bool IRhRdkNewContentCtrl::SetSelection ( const CRhRdkContentArray aContent)
pure virtual

Set the selected contents. Supports 'varies'.

Parameters
aContentis the array of contents.
Returns
true if successful, else false.

◆ SetSelection() [2/2]

virtual bool IRhRdkNewContentCtrl::SetSelection ( const CRhRdkInstanceIdArray aInstance)
pure virtual

Set the selected contents' instance ids. Supports 'varies'.

Parameters
aInstanceis the array of contents.
Returns
true if successful, else false.

◆ SetShowContextMenu()

virtual void IRhRdkNewContentCtrl::SetShowContextMenu ( bool  bShow)
pure virtual

Set whether or not a context menu is displayed.

◆ SetShowNewButtonInDropDown()

virtual void IRhRdkNewContentCtrl::SetShowNewButtonInDropDown ( bool  bShow)
pure virtual

Set whether or not a 'New' button is displayed in the drop-down list.

◆ SetShowPlugInItemInDropDown()

virtual void IRhRdkNewContentCtrl::SetShowPlugInItemInDropDown ( bool  bShow)
pure virtual

Set whether or not a 'plug-in' item is displayed in the drop-down list.

◆ ShowContextMenu()

virtual bool IRhRdkNewContentCtrl::ShowContextMenu ( void  ) const
pure virtual

Query whether or not a context menu is displayed.

◆ ShowNewButtonInDropDown()

virtual bool IRhRdkNewContentCtrl::ShowNewButtonInDropDown ( void  ) const
pure virtual

Query whether or not a 'New' button is displayed in the drop-down list.

◆ ShowPlugInItemInDropDown()

virtual bool IRhRdkNewContentCtrl::ShowPlugInItemInDropDown ( void  ) const
pure virtual

Query whether or not a 'plug-in' item is displayed in the drop-down list.

◆ UpdateView()

virtual void IRhRdkNewContentCtrl::UpdateView ( void  )
pure virtual

Refreshes the control.