Click or drag to resize

GH_ParamTCast_Object Method

Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected T Cast_Object(
	Object data
)

Parameters

data
Type: SystemObject

Return Value

Type: T
The cast value or Nothing on failure.
See Also