Click or drag to resize

GH_ParamTPreview_ComputeClippingBox Method

This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected BoundingBox Preview_ComputeClippingBox()

Return Value

Type: BoundingBox
The clipping box for all valid items.
See Also