Click or drag to resize

GH_Archive Methods

The GH_Archive type exposes the following members.

Methods
  NameDescription
Public methodAddMessage(GH_Message)
Add a new message to the record.
Public methodAddMessage(String, GH_Message_Type)
Add a new message to the record.
Public methodCode exampleAppendObject
Appends a target object into the root node of this archive tree. If the root doesn't exist yet, it will be created. Existing objects at the root scope will not be affected.
Public methodClearMessages
Remove all messages from the log.
Public methodCreateNewRoot
Discards the current data tree and instantiates a new root node. This root node contains some comments, a version value containing the current version of GH_IO.dll and a DateTime value containing the current date and time.
Public methodCreateTopLevelNode
Creates and returns a new root node for this archive in the form of a GH_IWriter instance. Typically you do not call this method. If you want to add an object to the archive, use AppendObject() instead.
Public methodDeserialize_Binary
Deserializes an array of bytes.
Public methodDeserialize_Xml
Deserializes an Xml string.
Public methodExtractObject
Extract a target object from the data tree.
Public methodMessageCount
Gets the number of messages recorded since the most recent IO operation began.
Public methodMessageCount(Boolean, Boolean, Boolean)
Gets the number of messages recorded since the most recent IO operation began. Message count can be filtered by message type.
Public methodStatic memberOpenFileDialog
Displays a standard OpenFileDialog with all the fields set to cater for Grasshopper files.
Public methodReadFromFile
Reads a new archive tree from a file.
Public methodStatic memberSaveFileDialog
Displays a standard SaveFileDialog with all the fields set to cater for Grasshopper files.
Public methodSerialize_Binary
Serializes the data tree into a Binary byte array.
Public methodSerialize_Xml
Serializes the data tree into an Xml string.
Public methodShowMessageLog
Displays the message log viewer. You should typically only display the viewer if the WorstCaseMessageType equals GH_Message_Type.warning or GH_Message_Type.error
Public methodWriteToFile
Writes the current tree to a file.
Top
See Also