Click or drag to resize

GH_ArchiveExtractObject Method

Extract a target object from the data tree.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public bool ExtractObject(
	GH_ISerializable target,
	string targetName
)

Parameters

target
Type: GH_IOGH_ISerializable
Object to extract. Cannot be null.
targetName
Type: SystemString
Name of object to extract, name must identify an existing chunk.

Return Value

Type: Boolean
True on succes, false on failure.
Exceptions
ExceptionCondition
MemberAccessExceptionThrown if the Root node hasn't been instantiated yet.
ArgumentNullExceptionThrown if target is a null reference.
ArgumentNullExceptionThrown if the target_name is null or empty.
MemberAccessExceptionThrown if the target_name cannot be resolved.
See Also