Click or drag to resize

GH_ColourCube Methods

The GH_ColourCube type exposes the following members.

Methods
  NameDescription
Public methodAverage(Color, Color)
Compute the average of two colours.
Public methodAverage(Color, Color, Color, Color)
Compute the average of four colours.
Public methodBlend
Inteprolate between two colours.
Public methodColorAtRail
Get the color at a position along the depth rail.
Public methodColorAtSlice
Get the color at a position on the slice.
Public methodRenderAll
Call all render methods in the correct order.
Public methodRenderBackEdges
Render the edges of the back face creases.
Public methodRenderBackFaces
Render the fills of the backfaces.
Public methodRenderDropShadow
Render the drop shadow of the cube.
Public methodRenderEdgeShadows
Render the edge shadows of the cube due to GI.
Public methodRenderForeEdges
Render the edges of the fore face creases.
Public methodRenderGrip
Render the slice grip.
Public methodRenderPivot
Render the colour pivot on the current slice.
Public methodRenderSilhouetteEdges
Render the edges of the cube silhouettes.
Public methodRenderSlice
Render the square slice with colour gradients.
Public methodRenderSliceDropShadow
Render the drop shadow onto the slice.
Public methodRenderSliceEdgeShadows
Render the edge shadows of the slice due to GI.
Public methodRenderSliceSilhouetteEdges
Render the silhouette edges of the slice.
Top
See Also