Click or drag to resize

GH_FontServer Methods

The GH_FontServer type exposes the following members.

Methods
  NameDescription
Public methodStatic memberFontToString
Convert a font to a string.
Public methodStatic memberMeasureString(String, Font)
Measure the size of a string
Public methodStatic memberMeasureString(String, Font, SizeF)
Measure the size of a string
Public methodStatic memberMeasureString(String, Font, Single)
Measure the size of a string
Public methodStatic memberNewFont(Font, FontStyle)
Safe font constructor.
Public methodStatic memberNewFont(Font, Single)
Safe font constructor.
Public methodStatic memberNewFont(FontFamily, Single)
Safe font constructor.
Public methodStatic memberNewFont(Font, Single, FontStyle)
Safe font constructor.
Public methodStatic memberNewFont(FontFamily, Single, FontStyle)
Safe font constructor.
Public methodStatic memberNewFont(String, Single, FontStyle)
High level function for Font creation. We've ran into loads of trouble in the past with missing Fonts. Never create a font directly via GDI+, always use this method.
Public methodStatic memberStringToFont
Convert a font description string back into a font.
Public methodStatic memberStringWidth(IEnumerableString, Font)
Measure the maximum width of a collection of strings
Public methodStatic memberStringWidth(String, Font)
Measure the width of a string in pixels
Top
See Also