GH_TaskCapableComponentT Properties |
The GH_TaskCapableComponentT generic type exposes the following members.
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes that are associated with this object.
Only set custom attributes if you know what you are doing.
(Inherited from GH_DocumentObject.) | |
CancelToken | ||
Category |
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
(Inherited from GH_InstanceDescription.) | |
ClippingBox |
Gets the clipping box for all preview geometry drawn by this component
and all associated parameters.
(Inherited from GH_Component.) | |
ComponentGuid |
Returns a consistent ID for this object type. Every object must supply a unique and unchanging
ID that is used to identify objects of the same type.
(Inherited from GH_DocumentObject.) | |
Description |
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from GH_InstanceDescription.) | |
Exposure |
Gets the exposure of this object in the Graphical User Interface.
The default is to expose everywhere.
(Inherited from GH_DocumentObject.) | |
HasCategory |
Gets whether or not the Category field has been set.
(Inherited from GH_InstanceDescription.) | |
HasSubCategory |
Gets whether or not the SubCategory field has been set.
(Inherited from GH_InstanceDescription.) | |
HelpDescription |
Override this method if you want the help topic content to be more than the Component description.
(Inherited from GH_Component.) | |
Hidden |
Gets or sets the hidden flag for this component.
Does not affect Hidden flags on parameters associated
with this component.
(Inherited from GH_Component.) | |
Icon |
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached,
so don't worry if icon retrieval is not very fast.
(Inherited from GH_DocumentObject.) | |
Icon_24x24 |
The icon associated with this object.
(Inherited from GH_DocumentObject.) | |
Icon_24x24_Locked |
The greyscale icon of this object.
(Inherited from GH_DocumentObject.) | |
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
and return False.
(Inherited from GH_ActiveObject.) | |
IconDisplayMode |
Gets the current display mode of the object.
(Inherited from GH_DocumentObject.) | |
InConstructor |
Gets the constructor flag for this instance. If InConstructor = True,
it means the component is still registering parameters and the
layout is not yet complete.
(Inherited from GH_Component.) | |
InPreSolve |
Is set to True by the framework right before a "use tasks" pass is made on
SolveIntance calls. When True, SolveInstance should be using Tasks to start
calculations on input data. When False, SolveInstance should be setting the
output data by either using the result of a task or directly computing the
results.
| |
InstanceDescription | (Overrides GH_ComponentInstanceDescription.) | |
InstanceGuid |
Gets the ID of this runtime instance.
(Inherited from GH_InstanceDescription.) | |
IsBakeCapable | (Inherited from GH_Component.) | |
IsDataProvider |
Components are never Data providers. Only the output parameters can be considered to be providers.
(Inherited from GH_Component.) | |
IsPreviewCapable |
If a single parameter is PreviewCapable, so is the component.
Override this property if you need special Preview flags.
(Inherited from GH_Component.) | |
IsValidPrincipalParameterIndex |
Gets whether the MasterParameterIndex property identifies a valid parameter.
(Inherited from GH_Component.) | |
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
can override this property to aid in object searches.
(Inherited from GH_InstanceDescription.) | |
Locked |
Gets or sets the Locked state for this Component.
This also sets locked states for all input and output parameters.
(Inherited from GH_Component.) | |
Message |
Gets or sets a custom message to be displayed underneath the component.
This message is not serialized and should be assigned on every solution anew.
(Inherited from GH_Component.) | |
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
The default is TRUE.
(Inherited from GH_ActiveObject.) | |
Name |
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
(Inherited from GH_InstanceDescription.) | |
NickName |
Gets or sets the nickname of the object. This field can be changed by the user.
(Inherited from GH_InstanceDescription.) | |
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
ObsoleteAttribute.
You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
(Inherited from GH_DocumentObject.) | |
Params |
Gets the parameter manager object for this component.
(Inherited from GH_Component.) | |
Phase |
Gets or sets the solution phase this object is currenly in.
(Inherited from GH_ActiveObject.) | |
PrincipalParameterIndex |
Gets or sets the principal parameter index override.
Negative indices or indices larger than or equal to the input parameter count will
be ignored and regular principal parameter detection will kick in.
(Inherited from GH_Component.) | |
ProcessorTime |
Gets the total processor time (profiler) spend by this component and all input parameters.
(Inherited from GH_Component.) | |
RunCount |
Gets a value indicating how many times the SolveInstance method was called on this component during the last solution.
This property will return -1 if no valid runcount is available.
(Inherited from GH_Component.) | |
RuntimeMessageLevel |
Returns the worst case runtime warning level of me and all my parameters
(Inherited from GH_Component.) | |
SubCategory |
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
(Inherited from GH_InstanceDescription.) | |
TaskList | ||
UseTasks |
Returns True if the component is set to support tasks. Components can have this
feature turned on/off. Note that even if UseTasks returns True, there is a chance
that a multipass task based solution may not be invoked depending on if multiple
calls need to be made during enumeration. You must pay attention to the value of
InPreSolve during SolveInstance.
The set version of this property can be called by the framework if we want to
provide a technique to globally turn on/off task support for all components in
a definition.
|