Click or drag to resize

GH_TaskCapableComponentT Class

Abstract implementation of IGH_TaskCapableComponent. Inherit from this class instead of implementing IGH_TaskCapableComponent directly.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_TaskCapableComponent<T> : GH_Component, 
	IGH_TaskCapableComponent

Type Parameters

T

The GH_TaskCapableComponentT type exposes the following members.

Properties
  NameDescription
Protected propertyCancelToken
Public propertyInPreSolve
Is set to True by the framework right before a "use tasks" pass is made on SolveIntance calls. When True, SolveInstance should be using Tasks to start calculations on input data. When False, SolveInstance should be setting the output data by either using the result of a task or directly computing the results.
Public propertyInstanceDescription (Overrides GH_ComponentInstanceDescription.)
Protected propertyTaskList
Public propertyUseTasks
Returns True if the component is set to support tasks. Components can have this feature turned on/off. Note that even if UseTasks returns True, there is a chance that a multipass task based solution may not be invoked depending on if multiple calls need to be made during enumeration. You must pay attention to the value of InPreSolve during SolveInstance. The set version of this property can be called by the framework if we want to provide a technique to globally turn on/off task support for all components in a definition.
Top
Methods
  NameDescription
Protected methodAfterSolveInstance (Overrides GH_ComponentAfterSolveInstance.)
Public methodAppendAdditionalMenuItems (Overrides GH_ComponentAppendAdditionalMenuItems(ToolStripDropDown).)
Protected methodGetSolveResults
Call this method to await the associated task and retrieve its data.
Public methodOnUseTasksClicked
Public methodRead (Overrides GH_ComponentRead(GH_IReader).)
Public methodRequestTaskCancellation
Called by the framework when solving has been interrupted and tasks do not need to complete.
Public methodWrite (Overrides GH_ComponentWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
Fields
  NameDescription
Top
See Also