Click or drag to resize

GH_DigitScrollerBase Class

Provides Numeric digit scrolling GUI not tied to a control-handle.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DigitScrollerBase : GH_TextBoxInputBase

The GH_DigitScrollerBase type exposes the following members.

Constructors
  NameDescription
Public methodGH_DigitScrollerBase
Initializes a new instance of the GH_DigitScrollerBase class
Top
Properties
  NameDescription
Public propertyAllowRadixDrag
Gets or sets a value indicating whether the radix is allowed to be dragged around.
Public propertyAllowTextInput
Gets or sets whether text input is allowed by double click.
Public propertyAmplifyMotion
Gets or sets a value indicating whether vertical mouse drags should be amplified as the mouse moves further and further.
Public propertyBackgroundGradient
Gets or sets the background Gradient. If the gradient is not null, it overrides the background colours.
Public propertyBottomColour
Gets or sets the colour used along the bottom edge of the control.
Public propertyBounds
Gets or sets the Bounds for this scroller.
(Overrides GH_TextBoxInputBase.Bounds.)
Public propertyDecimalPlaces
Gets or sets the number of decimal places available in this scroller. Unlike Radix, this property maintains the decimal position of the value represented by this scroller.
Public propertyDigitAlign
Gets or sets the digit align mode.
Public propertyDigits
Gets or sets the number of digits available in this scroller.
Public propertyDrawBackground
Gets or sets whether the background is drawn in this control.
Public propertyDrawBorder
Gets or sets whether the border is drawn in this control.
Public propertyDrawShadows
Gets or sets whether shadows are drawn in this control.
Public propertyEdgeColour
Gets or sets the edge colour of the control.
Public propertyEpsilon
Gets the smallest possible change in the value.
Public propertyFont
Gets or sets the Font for this scroller.
(Overrides GH_TextBoxInputBaseFont.)
Public propertyMaximumValue
Gets or sets the upper bound of the scroll value.
Public propertyMinimumValue
Gets or sets the lower bound of the scroll value.
Public propertyPrefix
Gets or sets the prefix text to be displayed on the scroller.
Public propertyPrefixBox
Gets the box containing the prefix string. If there is no prefix the PrefixBox will be Rectangle.Empty
Public propertyRadix
Gets or sets the radix index of this scroller.
Public propertyRadixBox
Gets the Radix box for this control, if there is no radix box, Rectangle.Empty will be returned.
Public propertyRailColour
Gets or sets the colour used for the rail line.
Public propertyRaiseEvents
Gets or sets whether this scroller raises the ValueChanged event.
Public propertyScrollBoxes
Gets all scroll boxes (from left to right) for this control, not including the radix box.
Public propertyShadowColour
Gets or sets the colour used for the shadows.
Public propertyShadowSize
Gets or sets the size of the drop shadow along all four edges.
Public propertySignBox
Gets the Sign box for this control.
Public propertySuffix
Gets or sets the suffix text to be displayed on the scroller.
Public propertySuffixBox
Gets the box containing the suffix string. If there is no suffix the PrefixBox will have zero width
Public propertyTextColour
Gets or sets the colour used for the text inside the scrolls.
Public propertyTopColour
Gets or sets the colour used along the top edge of the control.
Public propertyValue
Gets or sets the value displayed in this scroller.
Top
Methods
  NameDescription
Protected methodHandleTextInputAccepted (Overrides GH_TextBoxInputBaseHandleTextInputAccepted(String).)
Public methodMouseDown
Respond to mouse-down events.
Public methodMouseMove
Respond to mouse-move events.
Public methodMouseUp
Respond to mouse-up events.
Public methodOnInvalidated
Raise the Invalidated event.
Public methodOnValueChanged
Raise the ValueChanged event.
Public methodRender
Render all UI elements.
Public methodSetupScroller
Set the minimum, maximum and value fields simultaneously.
Public methodShowTextInputBox(Control)
Public methodShowTextInputBox(Control, Boolean)
Public methodShowTextInputBox(Control, Boolean, Matrix)
Top
Events
  NameDescription
Public eventInvalidated
Raised whenever the display of this scroller is changed, but not the value.
Public eventValueChanged
Raised whenever the value of this scroller is changed due to User-Interface methods.
Top
See Also