GH_Circle Class |
Namespace: Grasshopper.Kernel.Types
The GH_Circle type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Circle |
Default constructor
|
![]() | GH_Circle(Circle) |
Create a duplicate of another circle
|
![]() | GH_Circle(GH_Circle) |
Create a duplicate of another circle.
|
Name | Description | |
---|---|---|
![]() | Boundingbox |
Gets the boundingbox for this geometry.
(Overrides GH_GeometricGooTBoundingbox.) |
![]() | ClippingBox | |
![]() | IsGeometryLoaded |
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced).
Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
(Inherited from GH_GeometricGooT.) |
![]() | IsReferencedGeometry |
Gets a value indicating whether or not this geometry is referenced.
Not all IGH_GeometricGoo implementations support referenced geometry.
(Inherited from GH_GeometricGooT.) |
![]() | IsValid |
Gets the validity of this instance.
Circles are valid when their base planes are valid and when the radius is larger than zero.
(Overrides GH_GeometricGooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) |
![]() | ReferenceID |
Gets or sets the Guid of the object that is referenced.
Not all IGH_GeometricGoo implementations support referenced geometry.
The default implementation is to always return Guid.Empty.
(Inherited from GH_GeometricGooT.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value |
Gets or sets the value of this type.
Note that if the type has a ReferenceID this value might get destroyed in the future.
(Inherited from GH_GeometricGooT.) |
Name | Description | |
---|---|---|
![]() | BakeGeometry | |
![]() | CastFrom |
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).) |
![]() | CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).) |
![]() | CastToQ(Q) |
Attempt a cast to type T.
(Inherited from GH_GeometricGooT.) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | ClearCaches |
Clears all caches. Typically if the geometry is referenced, this will erase the local copy.
If your T is a value-type, you must override this function and specifically unset the local value.
(Inherited from GH_GeometricGooT.) |
![]() | DrawViewportMeshes | |
![]() | DrawViewportWires | |
![]() | Duplicate | (Overrides GH_GeometricGooTDuplicate.) |
![]() | DuplicateCircle |
Create a duplicate of this circle.
|
![]() | DuplicateGeometry |
Create a duplicate of this circle.
(Overrides GH_GeometricGooTDuplicateGeometry.) |
![]() | EmitProxy |
Returns a proxy that represents this circle. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.) |
![]() | GetBoundingBox | (Overrides GH_GeometricGooTGetBoundingBox(Transform).) |
![]() | LoadGeometry |
If the geometry is referenced and currently unloaded, forces loading of the geometry.
Not all IGH_GeometricGoo implementations support referenced geometry.
(Inherited from GH_GeometricGooT.) |
![]() | LoadGeometry(RhinoDoc) |
If the geometry is referenced and currently unloaded, forces loading of the geometry.
Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
(Inherited from GH_GeometricGooT.) |
![]() | Morph | (Overrides GH_GeometricGooTMorph(SpaceMorph).) |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ScriptVariable |
This function will be called when the local IGH_Goo instance
disappears into a user Script. This would be an excellent place to
cast your IGH_Goo type to a simple data type.
(Inherited from GH_GooT.) |
![]() | ToString |
Format the circle using default grasshopper formatting logic.
(Overrides GH_GooTToString.) |
![]() | Transform | (Overrides GH_GeometricGooTTransform(Transform).) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |