Description:

Adds a polygon to the drawing list. Polygons are not like Hatches, when you supply a concave polygon, the shading probably won't work.

Syntax:
public void AddPolygon(
IEnumerable<Point3d> polygon,
Color fillColor,
Color edgeColor,
bool drawFill,
bool drawEdge
)
Parameters:
  • polygon
  • Type: IEnumerable<Point3d>
  • Points that define the corners of the polygon.
  • fillColor
  • Type: Color
  • Fill color of polygon.
  • edgeColor
  • Type: Color
  • Edge color of polygon.
  • drawFill
  • Type: bool
  • If true, the polygon contents will be drawn.
  • drawEdge
  • Type: bool
  • If true, the polygon edge will be drawn.
Returns:
Type: void
Available since:
5.0

AddPolygon method

Class:  Rhino.Display.CustomDisplay

Nothing found