Description:

Adds a new linetype with specified definition to the linetype table.

Syntax:
public int Add(
Linetype linetype
)
Parameters:
  • linetype
  • Type: DocObjects.Linetype
  • Definition of new linetype. The information in linetype is copied. If linetype.Name is empty then a unique name of the form "Linetype 01" will be automatically created.
Returns:
Type: int
Index of newline type or -1 on error.
Available since:
5.0

Description:

Adds a new linetype with specified definition to the linetype table.

Syntax:
public int Add(
string name,
IEnumerable<double> segmentLengths
)
Parameters:
  • name
  • Type: string
  • A name for the new linetype.
  • segmentLengths
  • Type: IEnumerable<double>
  • Positive values are dashes, negative values are gaps.
Returns:
Type: int
Index of new linetype or -1 on error.
Available since:
5.0

Nothing found