Description:

Obsolete. Use the other overload.

Syntax:
public int Find(
string name,
bool ignoreDeletedLinetypes
)
deprecated in 6.0
obsolete: ignoreDeletedLinetypes is now ignored. Items are removed permanently now. Remove the second method argument.
Parameters:
  • name
  • Type: string
  • search ignores case.
  • ignoreDeletedLinetypes
  • Type: bool
  • If true, deleted linetypes are not checked.
Returns:
Type: int
>=0 index of the linetype with the given name -1 no linetype has the given name.
Available since:
5.0

Description:

Finds the linetype with a given name.

Syntax:
public int Find(
string name
)
Parameters:
  • name
  • Type: string
  • The name of the linetype to find. The search ignores case.
Returns:
Type: int
If the linetype was found, the linetype index, >=0, is returned. If the linetype was not found, -1 is returned. Note, the linetype index of -1 denotes the default, or "Continuous" linetype.
Available since:
6.0

Description:

Finds a linetype with a matching ID.

Syntax:
public int Find(
Guid id,
bool ignoreDeletedLinetypes
)
Parameters:
  • id
  • Type: System.Guid
  • The ID of the line type to be found.
  • ignoreDeletedLinetypes
  • Type: bool
  • If true, deleted linetypes are not checked.
Returns:
Type: int
If the linetype was found, the linetype index, >=0, is returned. If the linetype was not found, -1 is returned. Note, the linetype index of -1 denotes the default, or "Continuous" linetype.
Available since:
5.0

Nothing found