Description:

Maps 2D geometry from the squished surface or mesh back to the original 3D surface or mesh

Syntax:
public static IEnumerable<GeometryBase> SquishBack2dMarks(
GeometryBase squishedGeometry,
IEnumerable<GeometryBase> marks
)
Parameters:
  • squishedGeometry
  • Type: GeometryBase
  • The squished surface or mesh
  • marks
  • Type: IEnumerable<GeometryBase>
  • The input 2D geometry
Returns:
Type: IEnumerable<GeometryBase>
An enumeratd list of squished marks. Individual marks that fail to squish are None in this list. Returns None on complete failure.
Available since:
7.9

/
/
/
SquishBack2dMarks

SquishBack2dMarks method

Class:  Rhino.Geometry.Squisher

Nothing found