Description:

Squish the surface into a flat brep

Syntax:
public Brep SquishSurface(
SquishParameters sp,
Surface surface,
IEnumerable<GeometryBase> marks,
List<GeometryBase> squished_marks_out
)
Parameters:
  • surface
  • Type: Surface
  • The surface to be squished
  • marks
  • Type: IEnumerable<GeometryBase>
  • Point, PountCloud, TextDot, and Curve objects to squish. Can be null.
  • squished_marks_out
  • Type: List<GeometryBase>
  • A list of the squished marks, with None entries for marks that fail to squish. Can be null.
Returns:
Type: Brep
A brep representing the flattened surface
Available since:
7.9

Description:

Squish the surface into a flat brep

Syntax:
public Brep SquishSurface(
SquishParameters sp,
Surface surface
)
Parameters:
  • surface
  • Type: Surface
  • The surface to be squished
Returns:
Type: Brep
A brep representing the flattened surface
Available since:
7.9

SquishSurface method

Class:  Rhino.Geometry.Squisher

Nothing found