Description:

Get a cylindrical projection parameters from this texture mapping.

Syntax:
public bool TryGetMappingCylinder(
out Cylinder cylinder,
out bool capped
)
Parameters:
  • capped
  • Type: bool
  • will be True if capped
Returns:
Type: bool
Returns True if a valid cylinder is returned.
Remarks:
Generally, GetMappingCylinder will not return the same parameters passed to SetCylinderMapping. However, the location of the cylinder will be the same. If this mapping is not cylindrical, the cylinder will approximate the actual mapping primitive.
Available since:
6.7

Description:

Get a cylindrical projection parameters from this texture mapping.

Syntax:
public bool TryGetMappingCylinder(
out Cylinder cylinder
)
Returns:
Type: bool
Returns True if a valid cylinder is returned.
Remarks:
Generally, GetMappingCylinder will not return the same parameters passed to SetCylinderMapping. However, the location of the cylinder will be the same. If this mapping is not cylindrical, the cylinder will approximate the actual mapping primitive.
Available since:
5.10

/
/
/
TryGetMappingCylinder

TryGetMappingCylinder method

Class:  Rhino.Render.TextureMapping

Nothing found