Description:

Create a planar projection texture mapping

Syntax:
public static TextureMapping CreatePlaneMapping(
Plane plane,
Interval dx,
Interval dy,
Interval dz,
bool capped
)
Parameters:
  • plane
  • Type: Plane
  • A plane to use for mapping.
  • dx
  • Type: Interval
  • portion of the plane's x axis that is mapped to [0,1] (can be a decreasing interval)
  • dy
  • Type: Interval
  • portion of the plane's y axis that is mapped to [0,1] (can be a decreasing interval)
  • dz
  • Type: Interval
  • portion of the plane's z axis that is mapped to [0,1] (can be a decreasing interval)
  • capped
  • Type: bool
  • set to True if planar UVW is meant, False for planar UV
Returns:
TextureMapping instance if input is valid
Available since:
6.7

Description:

Create a planar UV projection texture mapping

Syntax:
public static TextureMapping CreatePlaneMapping(
Plane plane,
Interval dx,
Interval dy,
Interval dz
)
Parameters:
  • plane
  • Type: Plane
  • A plane to use for mapping.
  • dx
  • Type: Interval
  • portion of the plane's x axis that is mapped to [0,1] (can be a decreasing interval)
  • dy
  • Type: Interval
  • portion of the plane's y axis that is mapped to [0,1] (can be a decreasing interval)
  • dz
  • Type: Interval
  • portion of the plane's z axis that is mapped to [0,1] (can be a decreasing interval)
Returns:
TextureMapping instance if input is valid
Available since:
5.0

/
/
/
CreatePlaneMapping

CreatePlaneMapping method

Class:  Rhino.Render.TextureMapping

Nothing found