Description:

Get a box projection from the texture mapping, including capped information

Syntax:
public bool TryGetMappingBox(
out Plane plane,
out Interval dx,
out Interval dy,
out Interval dz,
out bool capped
)
Parameters:
  • plane
  • Type: Plane
  • The center of the box is at plane.origin and the sides of the box are parallel to the plane's coordinate planes.
  • dx
  • Type: Interval
  • The "front" and "back" sides of the box are in spanned by the vectors plane.yaxis and plane.zaxis. The back plane contains the point plane.PointAt(dx[0],0,0) and the front plane contains the point plane.PointAt(dx[1],0,0).
  • dy
  • Type: Interval
  • The "left" and "right" sides of the box are in spanned by the vectors plane.zaxis and plane.xaxis. The left plane contains the point plane.PointAt(0,dx[0],0) and the back plane contains the point plane.PointAt(0,dy[1],0).
  • dz
  • Type: Interval
  • The "top" and "bottom" sides of the box are in spanned by the vectors plane.xaxis and plane.yaxis. The bottom plane contains the point plane.PointAt(0,0,dz[0]) and the top plane contains the point plane.PointAt(0,0,dz[1]).
  • capped
  • Type: bool
  • True if box mapping is capped.
Returns:
Type: bool
Returns True if a valid box is returned.
Remarks:
Generally, GetMappingBox will not return the same parameters passed to SetBoxMapping. However, the location of the box will be the same.
Available since:
6.7

Description:

Get a box projection from the texture mapping.

Syntax:
public bool TryGetMappingBox(
out Plane plane,
out Interval dx,
out Interval dy,
out Interval dz
)
Parameters:
  • plane
  • Type: Plane
  • The center of the box is at plane.origin and the sides of the box are parallel to the plane's coordinate planes.
  • dx
  • Type: Interval
  • The "front" and "back" sides of the box are in spanned by the vectors plane.yaxis and plane.zaxis. The back plane contains the point plane.PointAt(dx[0],0,0) and the front plane contains the point plane.PointAt(dx[1],0,0).
  • dy
  • Type: Interval
  • The "left" and "right" sides of the box are in spanned by the vectors plane.zaxis and plane.xaxis. The left plane contains the point plane.PointAt(0,dx[0],0) and the back plane contains the point plane.PointAt(0,dy[1],0).
  • dz
  • Type: Interval
  • The "top" and "bottom" sides of the box are in spanned by the vectors plane.xaxis and plane.yaxis. The bottom plane contains the point plane.PointAt(0,0,dz[0]) and the top plane contains the point plane.PointAt(0,0,dz[1]).
Returns:
Type: bool
Returns True if a valid box is returned.
Remarks:
Generally, GetMappingBox will not return the same parameters passed to SetBoxMapping. However, the location of the box will be the same.
Available since:
5.10

TryGetMappingBox method

Class:  Rhino.Render.TextureMapping

Nothing found