Description:

Evaluate the mapping to get a texture coordinate

Syntax:
public int Evaluate(
Point3d p,
Vector3d n,
out Point3d t,
Transform pXform,
Transform nXform
)
Parameters:
  • n
  • Type: Vector3d
  • If the mapping projection is ray_projection, then this is the vertex unit normal. Otherwise n is ignored.
  • t
  • Type: Point3d
  • Texture coordinate (u,v,w)
  • pXform
  • Type: Transform
  • Transformation to be applied to P before performing the mapping calculation.
  • nXform
  • Type: Transform
  • Transformation to be applied to N before performing the mapping calculation. One way to calculate nXxform is to use the call pXform::GetVectorTransform(nXform).
Returns:
Type: int
Nonzero if evaluation is successful. When the mapping is a box or capped cylinder mapping, the value indicates which side was evaluated. Cylinder mapping: 1 = cylinder wall, 2 = bottom cap, 3 = top cap Box mapping: 1 = front, 2 = right, 3 = back, 4 = left, 5 = bottom, 6 = top
Available since:
6.17

Description:

Evaluate the mapping to get a texture coordinate

Syntax:
public int Evaluate(
Point3d p,
Vector3d n,
out Point3d t
)
Parameters:
  • n
  • Type: Vector3d
  • If the mapping projection is ray_projection, then this is the vertex unit normal. Otherwise n is ignored.
  • t
  • Type: Point3d
  • Texture coordinate (u,v,w)
Returns:
Type: int
Nonzero if evaluation is successful. When the mapping is a box or capped cylinder mapping, the value indicates which side was evaluated. Cylinder mapping: 1 = cylinder wall, 2 = bottom cap, 3 = top cap Box mapping: 1 = front, 2 = right, 3 = back, 4 = left, 5 = bottom, 6 = top
Available since:
6.17

Nothing found