Click or drag to resize

GH_AttributesTPrepareForRender Method

This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected virtual void PrepareForRender(
	GH_Canvas canvas
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas that is about to render these attributes.
See Also