Click or drag to resize

GH_AttributesTRender Method

Override this function to supply custom Render logic.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected virtual void Render(
	GH_Canvas canvas,
	Graphics graphics,
	GH_CanvasChannel channel
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas in which these attributes are to be drawn.
graphics
Type: System.DrawingGraphics
Graphics object to draw with.
channel
Type: Grasshopper.GUI.CanvasGH_CanvasChannel
Current drawing channel.
See Also