Click or drag to resize

GH_Attributes<T>.SolvePathBoxPick Method

Utility function for testing window selections with freeform Graphics paths.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool SolvePathBoxPick(
	GraphicsPath path,
	RectangleF box,
	float fuzz,
	GH_PickBox mode
)

Parameters

path
Type: System.Drawing.Drawing2D.GraphicsPath
Path to test.
box
Type: System.Drawing.RectangleF
Window selection box.
fuzz
Type: System.Single
Fuzzy pixels around object.
mode
Type: Grasshopper.Kernel.GH_PickBox
Selection mode to apply.

Return Value

Type: Boolean
True if box contains the path.
See Also