Click or drag to resize

GH_AttributesTRenderToCanvas Method

Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void RenderToCanvas(
	GH_Canvas canvas,
	GH_CanvasChannel channel
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas to draw on.
channel
Type: Grasshopper.GUI.CanvasGH_CanvasChannel
Current drawing channel.

Implements

IGH_AttributesRenderToCanvas(GH_Canvas, GH_CanvasChannel)
See Also