GH_AnnotationBase Methods |
The GH_AnnotationBase type exposes the following members.
Name | Description | |
---|---|---|
CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
ClearCaches |
Clears all volatile caches for this instance. The boundingbox is cleared, and if the annotation is referenced,
the local instance of the annotation is erased.
(Overrides GH_GeometricGooTClearCaches.) | |
CreateDisplay | ||
DrawViewportMeshes | ||
DrawViewportWires | ||
Duplicate | (Overrides GH_GeometricGooTDuplicate.) | |
DuplicateAnnotation |
Create a duplicate of this annotation.
| |
DuplicateGeometry |
Create a duplicate of this annotation.
GetBoundingBox | (Overrides GH_GeometricGooTGetBoundingBox(Transform).) | |
GetOverrides | ||
LoadGeometry |
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides GH_GeometricGooTLoadGeometry.) | |
LoadGeometry(RhinoDoc) |
If the annotation is referenced and not yet loaded, attempts to load the leader.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).) | |
Morph | (Overrides GH_GeometricGooTMorph(SpaceMorph).) | |
Read | (Overrides GH_GooTRead(GH_IReader).) | |
ScriptVariable | (Overrides GH_GooTScriptVariable.) | |
SetOverrides | ||
ToString |
Format the dimension using default grasshopper formatting logic.
(Overrides GH_GooTToString.) | |
Transform | (Overrides GH_GeometricGooTTransform(Transform).) | |
Write | (Overrides GH_GooTWrite(GH_IWriter).) |