Click or drag to resize

GH_Box Methods

The GH_Box type exposes the following members.

Methods
  NameDescription
Public methodAppendRenderGeometry
Public methodBakeGeometry
Public methodBrep
Differs from Rhino.Geometry.Brep.FromBox() because it Handles degenerate cases.
Public methodCastFrom (Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches (Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateBox
Public methodDuplicateGeometry (Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodEmitProxy (Overrides GH_GeometricGooTEmitProxy.)
Public methodGeometry
Convert the box to a GeometryBase instance.
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc) (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMesh
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also