GH_Box Class |
Namespace: Grasshopper.Kernel.Types
The GH_Box type exposes the following members.
Name | Description | |
---|---|---|
GH_Box | Initializes a new instance of the GH_Box class | |
GH_Box(BoundingBox) | Initializes a new instance of the GH_Box class | |
GH_Box(Box) | Initializes a new instance of the GH_Box class | |
GH_Box(GH_Box) | Initializes a new instance of the GH_Box class | |
GH_Box(Guid) | Initializes a new instance of the GH_Box class |
Name | Description | |
---|---|---|
Boundingbox | (Overrides GH_GeometricGooTBoundingbox.) | |
ClippingBox | ||
IsValid | (Overrides GH_GeometricGooTIsValid.) | |
IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) | |
ReferenceID | (Overrides GH_GeometricGooTReferenceID.) | |
TypeDescription | (Overrides GH_GooTTypeDescription.) | |
TypeName | (Overrides GH_GooTTypeName.) | |
Value | (Overrides GH_GeometricGooTValue.) |
Name | Description | |
---|---|---|
AppendRenderGeometry | ||
BakeGeometry | ||
Brep |
Differs from Rhino.Geometry.Brep.FromBox() because it Handles degenerate cases.
| |
CastFrom | (Overrides GH_GeometricGooTCastFrom(Object).) | |
ClearCaches | (Overrides GH_GeometricGooTClearCaches.) | |
DrawViewportMeshes | ||
DrawViewportWires | ||
Duplicate | (Overrides GH_GeometricGooTDuplicate.) | |
DuplicateBox | ||
DuplicateGeometry | (Overrides GH_GeometricGooTDuplicateGeometry.) | |
EmitProxy | (Overrides GH_GeometricGooTEmitProxy.) | |
Geometry |
Convert the box to a GeometryBase instance.
| |
LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).) | |
Mesh | ||
Morph | (Overrides GH_GeometricGooTMorph(SpaceMorph).) | |
ToString | (Overrides GH_GooTToString.) | |
Transform | (Overrides GH_GeometricGooTTransform(Transform).) | |
Write | (Overrides GH_GooTWrite(GH_IWriter).) |