Click or drag to resize

GH_Line Methods

The GH_Line type exposes the following members.

Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this line.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateLine
Create a duplicate of this line.
Public methodEmitProxy
Returns a proxy that represents this line. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the line using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also