Grasshopper API
Grasshopper API
Grasshopper.Kernel.Types
GH_Mesh Class
GH_Mesh Methods
AppendRenderGeometry Method
BakeGeometry Method
CastFrom Method
CastTo Method
ClearCaches Method
DrawViewportMeshes Method
DrawViewportWires Method
DuplicateGeometry Method
DuplicateMesh Method
EmitProxy Method
GetBoundingBox Method
LoadGeometry Method
Morph Method
Read Method
ScriptVariable Method
ToString Method
Transform Method
Write Method
GH_Mesh Methods
The
GH_Mesh
type exposes the following members.
Methods
Name
Description
AppendRenderGeometry
BakeGeometry
CastFrom
(Overrides
GH_GeometricGoo
T
CastFrom(Object)
.)
CastTo
Q
(Q
)
Attempt a cast to type T.
(Inherited from
GH_GeometricGoo
T
.)
CastTo
Q
(Q
)
Attempt a cast to type Q.
(Inherited from
GH_Goo
T
.)
CastTo
T
(T
)
(Overrides
GH_GeometricGoo
T
CastTo
Q
(Q
)
.)
ClearCaches
(Overrides
GH_GeometricGoo
T
ClearCaches
.)
DrawViewportMeshes
DrawViewportWires
Duplicate
Make a complete duplicate of this instance. No shallow copies.
(Inherited from
GH_GeometricGoo
T
.)
DuplicateGeometry
(Overrides
GH_GeometricGoo
T
DuplicateGeometry
.)
DuplicateMesh
EmitProxy
(Overrides
GH_GeometricGoo
T
EmitProxy
.)
GetBoundingBox
(Overrides
GH_GeometricGoo
T
GetBoundingBox(Transform)
.)
LoadGeometry
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides
GH_GeometricGoo
T
LoadGeometry
.)
LoadGeometry(RhinoDoc)
(Overrides
GH_GeometricGoo
T
LoadGeometry(RhinoDoc)
.)
Morph
(Overrides
GH_GeometricGoo
T
Morph(SpaceMorph)
.)
Read
(Overrides
GH_Goo
T
Read(GH_IReader)
.)
ScriptVariable
(Overrides
GH_Goo
T
ScriptVariable
.)
ToString
(Overrides
GH_Goo
T
ToString
.)
Transform
(Overrides
GH_GeometricGoo
T
Transform(Transform)
.)
Write
(Overrides
GH_Goo
T
Write(GH_IWriter)
.)
Top
See Also
Reference
GH_Mesh Class
Grasshopper.Kernel.Types Namespace
Grasshopper for Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com