Click or drag to resize

GH_Mesh Class

Represents a 3D polygonal mesh composed of quads and tris. GH_MEsh wraps the functionality of the OpenNURBS OnMesh class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooMesh
    Grasshopper.Kernel.TypesGH_GeometricGooMesh
      Grasshopper.Kernel.TypesGH_Mesh

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Mesh : GH_GeometricGoo<Mesh>, 
	IGH_BakeAwareData, IGH_PreviewData, IGH_RenderAwareData

The GH_Mesh type exposes the following members.

Constructors
  NameDescription
Public methodGH_Mesh
Initializes a new instance of the GH_Mesh class
Public methodGH_Mesh(GH_Mesh)
Initializes a new instance of the GH_Mesh class
Public methodGH_Mesh(Guid)
Initializes a new instance of the GH_Mesh class
Public methodGH_Mesh(Mesh)
Initializes a new instance of the GH_Mesh class
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded (Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid (Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodAppendRenderGeometry
Public methodBakeGeometry
Public methodCastFrom (Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches (Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicateGeometry (Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateMesh
Public methodEmitProxy (Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc) (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also