GH_Brep Class |
Namespace: Grasshopper.Kernel.Types
The GH_Brep type exposes the following members.
Name | Description | |
---|---|---|
GH_Brep | Initializes a new instance of the GH_Brep class | |
GH_Brep(Brep) | Initializes a new instance of the GH_Brep class | |
GH_Brep(GH_Brep) | Initializes a new instance of the GH_Brep class | |
GH_Brep(Guid) | Initializes a new instance of the GH_Brep class |
Name | Description | |
---|---|---|
Boundingbox | (Overrides GH_GeometricGooTBoundingbox.) | |
ClippingBox | ||
IsValid | (Overrides GH_GeometricGooTIsValid.) | |
IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) | |
ReferenceID | (Overrides GH_GeometricGooTReferenceID.) | |
TypeDescription | (Overrides GH_GooTTypeDescription.) | |
TypeName | (Overrides GH_GooTTypeName.) | |
Value | (Overrides GH_GeometricGooTValue.) |