Click or drag to resize

GH_Rectangle Class

Represents a 3D rectangle. GH_Rectangle re-implements the RhinoCommon Rectangle3d.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooRectangle3d
    Grasshopper.Kernel.TypesGH_GeometricGooRectangle3d
      Grasshopper.Kernel.TypesGH_Rectangle

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Rectangle : GH_GeometricGoo<Rectangle3d>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_Rectangle type exposes the following members.

Constructors
  NameDescription
Public methodGH_Rectangle
Default constructor
Public methodGH_Rectangle(GH_Rectangle)
Create a duplicate of another circle.
Public methodGH_Rectangle(Rectangle3d)
Create a duplicate of another rectangle.
Top
Properties
  NameDescription
Public propertyBoundingbox
Gets the boundingbox for this geometry.
(Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsValid
Gets the validity of this instance.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this rectangle.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateRectangle
Create a duplicate of this rectangle.
Public methodEmitProxy
Returns a proxy that represents this rectangle. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the circle using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also