Description:

Constructs a RGBA color from the four ARGB components (alpha, red, green, and blue) values.

Syntax:
public static ColorRGBA CreateFromArgb(
byte alpha,
byte red,
byte green,
byte blue
)
Parameters:
  • alpha
  • Type: byte
  • The alpha component. Valid values are 0 through 255.
  • red
  • Type: byte
  • The red component. Valid values are 0 through 255.
  • green
  • Type: byte
  • The green component. Valid values are 0 through 255.
  • blue
  • Type: byte
  • The blue component. Valid values are 0 through 255.
Returns:
Type: ColorRGBA
A RGBA color with the specified component values.
Available since:
8.0

Description:

Constructs a RGBA color from the specified 8-bit components (red, green, and blue) values. The alpha value is implicitly 1.0 (fully opaque).

Syntax:
public static ColorRGBA CreateFromArgb(
byte red,
byte green,
byte blue
)
Parameters:
  • red
  • Type: byte
  • The red component. Valid values are 0 through 255.
  • green
  • Type: byte
  • The green component. Valid values are 0 through 255.
  • blue
  • Type: byte
  • The blue component. Valid values are 0 through 255.
Returns:
Type: ColorRGBA
A RGBA color with the specified component values.
Available since:
8.0

CreateFromArgb method

Class:  Rhino.Display.ColorRGBA

Nothing found