Description:

Add a new face to the brep whose surface geometry is a ruled cone with the edge as the base and the vertex as the apex point.

Syntax:
public BrepFace AddConeFace(
BrepVertex vertex,
BrepEdge edge,
bool revEdge
)
Parameters:
  • vertex
  • Type: BrepVertex
  • The apex of the cone will be at this vertex. The north side of the surface's parameter space will be a singular point at the vertex.
  • edge
  • Type: BrepEdge
  • The south side of the face's surface will run along this edge.
  • revEdge
  • Type: bool
  • True if the new face's outer boundary orientation along the edge is opposite the orientation of edge.
Returns:
Type: BrepFace
Available since:
5.4

Nothing found