Description:

Add a new face to the brep whose surface geometry is a ruled surface between two edges.

Syntax:
public BrepFace AddRuledFace(
BrepEdge edgeA,
bool revEdgeA,
BrepEdge edgeB,
bool revEdgeB
)
Parameters:
  • edgeA
  • Type: BrepEdge
  • The south side of the face's surface will run along edgeA.
  • revEdgeA
  • Type: bool
  • True if the new face's outer boundary orientation along edgeA is opposite the orientation of edgeA.
  • edgeB
  • Type: BrepEdge
  • The north side of the face's surface will run along edgeA
  • revEdgeB
  • Type: bool
  • True if the new face's outer boundary orientation along edgeB is opposite the orientation of edgeB
Returns:
Type: BrepFace
Available since:
5.4

Nothing found